【Pytorch】cudaのバージョンに合わせてPytorchをインストールする方法【GPU】

スポンサーリンク

【Pytorch】cudaのバージョンに合わせてPytorchをインストールする方法【GPU】

GPUが使える環境でPytorchをインストールしたいときの方法をまとめる。

cudaのバージョンによってインストールするバージョンが異なるので注意。

cudaに適したバージョンを探す

以下のページにcudaのバージョンに対応したPytorchのバージョンを調べることができる。

PyTorch
An open source machine learning framework that accelerates the path from research prototyping to production deployment.

cudaのバージョンが10.1の場合は以下のように実行する。

pip3 install torch==1.8.1+cu101 torchvision==0.9.1+cu101 torchaudio==0.8.1 -f https://download.pytorch.org/whl/torch_stable.html

自分の環境ではPython3用にインストールする場合にはpip3を使うことになっている。

ここは環境によって適宜pipに変える

これでPytorchをインストールすることができた。

人気記事

人気記事はこちら。

CUDA、cuDNNのバージョンをターミナルで調べるコマンド
【Pytorch】テンソルを連結する方法(cat・stack)
【Pytorch】テンソルの次元を追加・削除する方法【dim】
【Protobuf】"TypeError: Descriptors cannot not be created directly."を解決する【solved】
【Python】Tensorflowをダウングレード・アップグレードするコマンド
タイトルとURLをコピーしました